Interface OWFS and FHEM

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Interface OWFS and FHEM

harry-th
This post has NOT been accepted by the mailing list yet.
Hello,
first of all I would like to thank you all for your contribution to this very valuable tool set.
I have compiled and installed the latest version of OWFS to my system (BananaPi running Bananian Linux and the latest Release of FHEM).
I am using the RPI2 I2C Module from Sheepwalkelectronics to access the 1-wire bus.
The installation works perfectly via the WEBinterface <MyIP>:2121
Also the installation of the FHEM component OWServer is working as expected (connects to OWFS).
I can see all my 1-wire devices and also can read data from them.
When I try to write data to a 1-wire component I have found out that there seem to be a mismatch at the interface:
when I e.g. write a temphigh value of  53 to a DS18B20 sensor I can read back the value 3 but if I write 053 then the correct value 53 is read back.
So my assumption is that there is a mismatch in the evaluation of the written data but my knowledge of the used programming languages is not sufficient to find out where this mismatch happens.
According to some threads in the FHEM forum the interface worked till OWFS version 2.8p15 but starting with owfs version 2.9 the described behaviour was observed.
When going back to the 2.8p15 everything worked as before.

Since this behaviour happened with different release versions of FHEM I would expect that the reason is on the OWFS part.

I would ask for some hints how to get further on this issue since I would like to use the latest version of OWFS and not be limited to using the 2.8p15.

Thanks in Advance

Harald