issues with owfs 2.8p15 on raspberry pi

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

issues with owfs 2.8p15 on raspberry pi

Thomas
Hello

I installed the owfs packages on my Pi (Raspbian - last release) : 2.8p15 is the last version.

I use /etc/owfs.conf file to facilitate the configuration. Here it is:

SERVER: -d /dev/i2c-1
SERVER: -p 4304
!SERVER: -s 4304
FS: -m /mnt/1wire
FS: allow_other
FS: nonempty
HTTP: -p 4444
#alias = /etc/owfs.alias
FTP: -p 2120

Then, I configure to start owserver, owfs and owhttpd that seem to work fine except that my 1-wire probes appear twice in the filesystem (1D & FF):

pi@Pi1Wire /mnt/1wire $ dir
total 4
0 drwxr-xr-x 1 root root    8 jun 26 15:13 .
4 drwxr-xr-x 4 root root 4096 jun 26 10:42 ..
0 drwxrwxrwx 1 root root    8 jun 26 15:19 1D.CBD90D000000
0 drwxrwxrwx 1 root root    8 jun 26 15:19 1D.CBD90D000000
0 drwxr-xr-x 1 root root    8 jun 26 15:13 alarm
0 drwxr-xr-x 1 root root    8 jun 26 15:13 bus.0
0 drwxr-xr-x 1 root root    8 jun 26 15:13 bus.1
0 drwxrwxrwx 1 root root    8 jun 26 15:19 FF.7D0800000100
0 drwxrwxrwx 1 root root    8 jun 26 15:19 FF.7D0800000100
0 drwxr-xr-x 1 root root    8 jun 26 15:13 settings
0 drwxr-xr-x 1 root root    8 jun 26 15:13 statistics
0 drwxr-xr-x 1 root root   32 jun 26 15:13 structure
0 drwxr-xr-x 1 root root    8 jun 26 15:13 system
0 drwxr-xr-x 1 root root    8 jun 26 15:13 uncached

Then, I cannot use owfs to read/write to 1wire

my second question is regarding the usage of alias inside the owfs.conf file
is it allowed touse that command at that place: alias = /etc/owfs.alias or is there another easier tip ?

Thank you

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

foster
1. double probes - it's bug in 2.8p15 version. If you want to upgrade to actual version, you need to uninstall this version via apt-get and then install manually actual version. But probably you will have the same problem like me - owserver will not start correctly. So I recommend to stay at 2.8p15 and not care about double probes.
2. if you start succesfully owserver you should be able to use commands in shell - owdir, owread owwrite -this commands works if you start owserver. If you use owfs, you can access directly to files in virtual filesystem(/mnt/1wire. If you have any errors, post them.
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Thomas
okay thanks for feedback.

However, I'm not able to use the FS /mnt/1wire due to the double post...


2013/6/26 foster <[hidden email]>
1. double probes - it's bug in 2.8p15 version. If you want to upgrade to
actual version, you need to uninstall this version via apt-get and then
install manually actual version. But probably you will have the same problem
like me - owserver will not start correctly. So I recommend to stay at
2.8p15 and not care about double probes.
2. if you start succesfully owserver you should be able to use commands in
shell - owdir, owread owwrite -this commands works if you start owserver. If
you use owfs, you can access directly to files in virtual
filesystem(/mnt/1wire. If you have any errors, post them.




--
View this message in context: http://owfs-developers.1086194.n5.nabble.com/issues-with-owfs-2-8p15-on-raspberry-pi-tp9751p9752.html
Sent from the OWFS Developers mailing list archive at Nabble.com.

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Paul Alfille-2
In reply to this post by foster
Tell me more about what won't start on the Pi? Is it that 2.8p15 owserver works but 2.9 owserver doesn't? Is there a particular error that you see?

I know you've posted extensively on a Pi problem, but it never registered that an older version worked for you. That's easier to run down.

Paul


On Wed, Jun 26, 2013 at 10:56 AM, foster <[hidden email]> wrote:
1. double probes - it's bug in 2.8p15 version. If you want to upgrade to
actual version, you need to uninstall this version via apt-get and then
install manually actual version. But probably you will have the same problem
like me - owserver will not start correctly. So I recommend to stay at
2.8p15 and not care about double probes.
2. if you start succesfully owserver you should be able to use commands in
shell - owdir, owread owwrite -this commands works if you start owserver. If
you use owfs, you can access directly to files in virtual
filesystem(/mnt/1wire. If you have any errors, post them.




--
View this message in context: http://owfs-developers.1086194.n5.nabble.com/issues-with-owfs-2-8p15-on-raspberry-pi-tp9751p9752.html
Sent from the OWFS Developers mailing list archive at Nabble.com.

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

foster
Hi Paul
In this topic http://owfs-developers.1086194.n5.nabble.com/can-t-start-owserver-td9556.html, I've tried to solve problem with startin owserver in 2.9 version. I was not able to solve, so I format sd card, install raspbian again and install owfs 2.8p15 via repository and owserve works ok.
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Thomas
In reply to this post by Paul Alfille-2
Hello Paul,

This is the first time I'm using OWFS on my new raspberry pi.

I tried the last CVS version and the packages available via apt-get install and I have today two issues (not linked according to me)

-with 2.8p15 available in package repossitory, in 1-wire filesystem, sensors appear twice. Seems to be corrected with 2.9p1. So I'll not use the filesystem to catch the data.
-with 2.8p15 & 2.9p1, the last character sent via owserver->write perl command is corrupted an wrongly displayed on Louis' LCD. No problem with owhttpd 2.8p15/2.9p1

Hope this clarifies my current issues

Thomas
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Jan Kandziora
Am 01.07.2013 14:15, schrieb Thomas:
>
> -with 2.8p15 & 2.9p1, the last character sent via owserver->write perl
> command is corrupted an wrongly displayed on Louis' LCD. No problem with
> owhttpd 2.8p15/2.9p1
>
Please connect ownet/perl on your PC with owserver on the Pi and vice
versa to find out who's the culprit.

Kind regards

        Jan


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Thomas
need to install Linux on my PC...not obvious @home (shared PC)

I'll try also from a sheevaplug runing Linux

Keep you informed


2013/7/1 Jan Kandziora <[hidden email]>
Am 01.07.2013 14:15, schrieb Thomas:
>
> -with 2.8p15 & 2.9p1, the last character sent via owserver->write perl
> command is corrupted an wrongly displayed on Louis' LCD. No problem with
> owhttpd 2.8p15/2.9p1
>
Please connect ownet/perl on your PC with owserver on the Pi and vice
versa to find out who's the culprit.

Kind regards

        Jan


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers


------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Jan Kandziora
Am 01.07.2013 16:47, schrieb Thomas Parvais:
> need to install Linux on my PC...not obvious @home (shared PC)
>
No, this isn't neccessary, as ownet/perl works on MS-Windows, too. It's
just a perl module doing some standard TCP/IP communication.

Kind regards

        Jan

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Colin Law-4
On 2 July 2013 22:57, Jan Kandziora <[hidden email]> wrote:
> Am 01.07.2013 16:47, schrieb Thomas Parvais:
>> need to install Linux on my PC...not obvious @home (shared PC)
>>
> No, this isn't neccessary, as ownet/perl works on MS-Windows, too. It's
> just a perl module doing some standard TCP/IP communication.

Go on, do it anyway :)
Set up your PC to dual boot between Win and Ubuntu and in no time you
will find that you (and hopefully those the PC is shared with) can
thrive without Windows.  It is great to feel that one is in control of
one's PC again.

Colin

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Guy COLIN
In reply to this post by Paul Alfille-2


Paul Alfille <paul.alfille <at> gmail.com> writes:

>
>
>
>
> Tell me more about what won't start on the Pi? Is it that 2.8p15 owserver
works but 2.9 owserver doesn't? Is there a particular error that you see?
> I know you've posted extensively on a Pi problem, but it never registered
that an older version worked for you. That's easier to run down.
> Paul
>
>
> On Wed, Jun 26, 2013 at 10:56 AM, foster <martinez.de.la.symbioz <at>
gmail.com> wrote:1. double probes - it's bug in 2.8p15 version. If you want
to upgrade to
> actual version, you need to uninstall this version via apt-get and then
> install manually actual version. But probably you will have the same
problem
> like me - owserver will not start correctly. So I recommend to stay at
> 2.8p15 and not care about double probes.
> 2. if you start succesfully owserver you should be able to use commands in
> shell - owdir, owread owwrite -this commands works if you start owserver.
If
> you use owfs, you can access directly to files in virtual
> filesystem(/mnt/1wire. If you have any errors, post them.
> --

>
Hello,

I confirm the same problem of double entries on Raspberry pi with i2c and
2.8p15. I recently moved from serial to i2c (DS2482-100 and DS2482-800 both
same issue).
root@raspberrypi:/home/pi# ll /mnt/1wire/
total 0
drwxrwxrwx 1 root root  8 Oct  9 12:26 10.9702E6010800
drwxrwxrwx 1 root root  8 Oct  9 12:26 10.9702E6010800
drwxr-xr-x 1 root root  8 Oct  9 11:27 alarm
drwxr-xr-x 1 root root  8 Oct  9 11:27 bus.0
drwxr-xr-x 1 root root  8 Oct  9 11:27 bus.1
drwxr-xr-x 1 root root  8 Oct  9 11:27 settings
drwxrwxrwx 1 root root  8 Oct  9 12:26 simultaneous
drwxr-xr-x 1 root root  8 Oct  9 11:27 statistics
drwxr-xr-x 1 root root 32 Oct  9 11:27 structure
drwxr-xr-x 1 root root  8 Oct  9 11:27 system
drwxr-xr-x 1 root root  8 Oct  9 11:27 uncached

However it works:
root@raspberrypi:/home/pi# cat /mnt/1wire/10.9702E6010800/temperature
      23.375

Yesterday I have switched on/off a relay via a PIO

I use owserver and owfs only (basic install via apt-get on Raspbian)
I have tried i2c advanced adressing to explicitly adress my DS2482 but no
success.
Anyway for the time it's only anoying, but still seems to work (to confirm
by real use, I'll do in a few weeks/months)

Thanks
--
Guy




------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

CReese
My experience with i2c (2483) on 2.8p15 was at first double and intermittent probes and then no probes. I upgraded to 2.9 and everything works.


On Wed, Oct 9, 2013 at 10:34 AM, Guy COLIN <[hidden email]> wrote:


Paul Alfille <paul.alfille <at> gmail.com> writes:

>
>
>
>
> Tell me more about what won't start on the Pi? Is it that 2.8p15 owserver
works but 2.9 owserver doesn't? Is there a particular error that you see?
> I know you've posted extensively on a Pi problem, but it never registered
that an older version worked for you. That's easier to run down.
> Paul
>
>
> On Wed, Jun 26, 2013 at 10:56 AM, foster <martinez.de.la.symbioz <at>
gmail.com> wrote:1. double probes - it's bug in 2.8p15 version. If you want
to upgrade to
> actual version, you need to uninstall this version via apt-get and then
> install manually actual version. But probably you will have the same
problem
> like me - owserver will not start correctly. So I recommend to stay at
> 2.8p15 and not care about double probes.
> 2. if you start succesfully owserver you should be able to use commands in
> shell - owdir, owread owwrite -this commands works if you start owserver.
If
> you use owfs, you can access directly to files in virtual
> filesystem(/mnt/1wire. If you have any errors, post them.
> --

>
Hello,

I confirm the same problem of double entries on Raspberry pi with i2c and
2.8p15. I recently moved from serial to i2c (DS2482-100 and DS2482-800 both
same issue).
root@raspberrypi:/home/pi# ll /mnt/1wire/
total 0
drwxrwxrwx 1 root root  8 Oct  9 12:26 10.9702E6010800
drwxrwxrwx 1 root root  8 Oct  9 12:26 10.9702E6010800
drwxr-xr-x 1 root root  8 Oct  9 11:27 alarm
drwxr-xr-x 1 root root  8 Oct  9 11:27 bus.0
drwxr-xr-x 1 root root  8 Oct  9 11:27 bus.1
drwxr-xr-x 1 root root  8 Oct  9 11:27 settings
drwxrwxrwx 1 root root  8 Oct  9 12:26 simultaneous
drwxr-xr-x 1 root root  8 Oct  9 11:27 statistics
drwxr-xr-x 1 root root 32 Oct  9 11:27 structure
drwxr-xr-x 1 root root  8 Oct  9 11:27 system
drwxr-xr-x 1 root root  8 Oct  9 11:27 uncached

However it works:
root@raspberrypi:/home/pi# cat /mnt/1wire/10.9702E6010800/temperature
      23.375

Yesterday I have switched on/off a relay via a PIO

I use owserver and owfs only (basic install via apt-get on Raspbian)
I have tried i2c advanced adressing to explicitly adress my DS2482 but no
success.
Anyway for the time it's only anoying, but still seems to work (to confirm
by real use, I'll do in a few weeks/months)

Thanks
--
Guy




------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers


------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Guy COLIN

Colin Reese <colin.reese <at> gmail.com> writes:

>
>
> My experience with i2c (2483) on 2.8p15 was at first double and
intermittent probes and then no probes. I upgraded to 2.9 and everything
works.


Hi Colin,

Was it on a Raspberry Pi?
Did you compile on the Pi itself?
The 2.9p1 and 2.9p0 release notes don't mention anything about such a fix.

Thanks
--
Guy


 




------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

CReese
It is on an RPi. I'll have to check to see whether its 2.9p0 or 2.9p1. I'll begin more complete testing this week and will get back to you.

I recompiled on the Pi after finding a google hit from this group on ds2483.

Colin


> On Oct 10, 2013, at 0:29, Guy COLIN <[hidden email]> wrote:
>
>
> Colin Reese <colin.reese <at> gmail.com> writes:
>
>>
>>
>> My experience with i2c (2483) on 2.8p15 was at first double and
> intermittent probes and then no probes. I upgraded to 2.9 and everything
> works.
>
>
> Hi Colin,
>
> Was it on a Raspberry Pi?
> Did you compile on the Pi itself?
> The 2.9p1 and 2.9p0 release notes don't mention anything about such a fix.
>
> Thanks
> --
> Guy
>
>
>
>
>
>
>
> ------------------------------------------------------------------------------
> October Webinars: Code for Performance
> Free Intel webinars can help you accelerate application performance.
> Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
> the latest Intel processors and coprocessors. See abstracts and register >
> http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
> _______________________________________________
> Owfs-developers mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/owfs-developers

------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Guy COLIN
Hello,

The double entries appear only in owfs
No double entries in owhttpd or owftpd
Version 2.8p15-1

Have a good day
--
Guy





------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: issues with owfs 2.8p15 on raspberry pi

Guy COLIN
Hello,

For me, this is now solved: I don't have anymore double entries in owfs
directory listing :-)

I'm not sure what exactly the root cause was, but I can tell what I did:
When I had double entries (each 1wire device was listed twice in owfs tree,
I had bus.0 and bus.1 with only 1 physical i2c device), I was using a RPI on
which I had made a lot of tests and many packages installed/removed.
Today I decided to put this RPI in real production (driving my home
automation) and re-insall everything on the SD card (not exactly a brand new
Raspbian but almost) then to have the i2c working I added these 2 lines at
the bottom of /etc/modules
i2c-bcm2708
i2c-dev
and then ran this command: apt-get install i2c-tools (because i2cdetect is a
convenient tool)
and this line in /etc/owfs.conf
server: device = /dev/i2c-1
That's it! Nothing else! It's perfectly working.

So I believe owfs was not the faulty, but something wrong with i2c modules
(actually it was the same), or a bad couple with owfs + another piece of
software.
Anyway with a clean Raspbian, owfs 2.8p15-1 (the one available via apt-get
install owfs directly from the Pi), and the here above lines it's working :-
)
Hope this will help.

Have a good 1wire day
--
Guy


------------------------------------------------------------------------------
October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
http://pubads.g.doubleclick.net/gampad/clk?id=60134071&iu=/4140/ostg.clktrk
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers