libusb-1.0 required version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

libusb-1.0 required version

Thomas Zimmermann
Hi,
I've just tried to compile 3.1p5 and recognized that since the addition of
owusbprobe at least libusb-1.0 >= 1.0.16 is required, as the libusb_strerror
function was added in this release. Perhaps someone can update the required
version in the configure.ac.

Thanks,
Thomas


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: libusb-1.0 required version

Johan Ström-3
Unfortunately FreeBSD advertises it's libusb-1.0 layer (which have
libusb_strerror) as 1.0.9, so just bumping the requirement to 1.0.16
will break build on FreeBSD.

A quick but ugly solution would just be to #ifdef out the calls to
libusb_strerror. Other suggestions?


On 11/02/17 10:51, Thomas Zimmermann wrote:

> Hi,
> I've just tried to compile 3.1p5 and recognized that since the addition of
> owusbprobe at least libusb-1.0 >= 1.0.16 is required, as the libusb_strerror
> function was added in this release. Perhaps someone can update the required
> version in the configure.ac.
>
> Thanks,
> Thomas
>
>
> ------------------------------------------------------------------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, SlashDot.org! http://sdm.link/slashdot
> _______________________________________________
> Owfs-developers mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/owfs-developers


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers
Reply | Threaded
Open this post in threaded view
|

Re: libusb-1.0 required version

Jan Kandziora
Am 05.03.2017 um 17:31 schrieb Johan Ström:
> Unfortunately FreeBSD advertises it's libusb-1.0 layer (which have
> libusb_strerror) as 1.0.9, so just bumping the requirement to 1.0.16
> will break build on FreeBSD.
>
> A quick but ugly solution would just be to #ifdef out the calls to
> libusb_strerror. Other suggestions?
>
With an AC_ macro? Then, I don't see problems with that approach. We
have numerous of those quirks in the sources already.

Kind regards

        Jan

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Owfs-developers mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/owfs-developers